We are showing all inbound calling issues from Lumen resolved at this time. We are still investigating the root cause of the issue. We will release more information on this as soon as we have it.
Our Engineers will continue to monitor the situation closely throughout the rest of the day.
Posted Sep 17, 2025 - 12:30 CDT
Update
Inbound calling from Lumen is fully down. Other carrier calls are connecting normally. Our Engineers are on a call with Lumen's team now working to resolve this issue. We discovered a routing change at Lumen that was made 7 hours ago that may have initiated these issues. Investigations are ongoing. We will release more information as soon as we have it.
Posted Sep 17, 2025 - 11:41 CDT
Identified
We were made aware from our engineering team that the inbound calling issues are from Lumen. The results are one way audio and phone registration issues. At this time there is no workaround for this issue. We will follow-up shortly once we have an update from Lumen.
Posted Sep 17, 2025 - 11:05 CDT
This incident affected: Flux Voice (Inbound & Outbound Calling).